summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-06-27 23:03:53 +0200
committerGitHub <noreply@github.com>2017-06-27 23:03:53 +0200
commit153116f7fd955bbcfee5fe80996a4619c7a343c3 (patch)
tree8bbe02cdfdd4720cce9c69f2f552775338f66038 /CMakeLists.txt
parent00291fd1811eba348f649f74f4c727625f0be945 (diff)
parenta2f1f76dc38a34d0e3d97f75d1fee527931b6e8a (diff)
Merge pull request #209 from philipturnbull/libFuzzer
Add libFuzzer harness for oss-fuzz
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e60fd5..33180e5 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,7 @@ set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_
option(CMARK_TESTS "Build cmark tests and enable testing" ON)
option(CMARK_STATIC "Build static libcmark library" ON)
option(CMARK_SHARED "Build shared libcmark library" ON)
+option(CMARK_LIB_FUZZER "Build libFuzzer fuzzing harness" OFF)
add_subdirectory(src)
if(CMARK_TESTS AND CMARK_SHARED)