summaryrefslogtreecommitdiff
path: root/man/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2019-12-22 10:32:57 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2020-01-02 22:58:05 -0700
commit828eeaf8960a347777f34ed134c5211717f1d446 (patch)
tree02254da7ea05c208b35e65cb50ff4c9e43e085e6 /man/CMakeLists.txt
parentb7188e8c1bfe0e148c3d3e6d08a9004cdfb2264d (diff)
build: improve man page installation
man pages are extremely useful, but are not generally available on Windows. This changes the install condition to check for the Windows cross-compile rather than the toolchain in use. It is possible to build for Windows using clang in the GNU driver.
Diffstat (limited to 'man/CMakeLists.txt')
-rw-r--r--man/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
index 13e8742..8ed5448 100644
--- a/man/CMakeLists.txt
+++ b/man/CMakeLists.txt
@@ -1,7 +1,4 @@
-if (NOT MSVC)
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man1/cmark.1
- DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
-
- install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man3/cmark.3
- DESTINATION ${CMAKE_INSTALL_MANDIR}/man3)
-endif(NOT MSVC)
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man1/cmark.1
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
+install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man3/cmark.3
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man3)