summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-12-04 23:13:54 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-12-04 23:13:54 -0800
commit27bd6c0b18318a9c43801409bbababf2ceb6302e (patch)
tree9a0bf89df4ffc1e47346c6958e62d193f918c660 /src/CMakeLists.txt
parented17cfc71a19e614a437581b6991a43d06ca6e01 (diff)
Moved source files from src/html into src.
The separate directory presents problems for some simple extension building systems, like luarocks.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d9af586..1377d60 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -12,8 +12,8 @@ set(HEADERS
utf8.h
scanners.h
inlines.h
- html/html_unescape.h
- html/houdini.h
+ html_unescape.h
+ houdini.h
)
set(LIBRARY_SOURCES
cmark.c
@@ -26,11 +26,11 @@ set(LIBRARY_SOURCES
utf8.c
buffer.c
references.c
- html/html.c
- html/html_unescape.gperf
- html/houdini_href_e.c
- html/houdini_html_e.c
- html/houdini_html_u.c
+ html.c
+ html_unescape.gperf
+ houdini_href_e.c
+ houdini_html_e.c
+ houdini_html_u.c
${HEADERS}
)
@@ -40,7 +40,7 @@ set(PROGRAM_SOURCES
main.c
)
-include_directories(. html ${CMAKE_CURRENT_BINARY_DIR})
+include_directories(. ${CMAKE_CURRENT_BINARY_DIR})
set(RE2C re2c)
if (MSVC)