summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2017-10-19 14:20:26 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2017-10-19 14:27:05 +0200
commit4f98864eb2781a8635e94d98f550100b1fa4add2 (patch)
treeb2ed5eb3598e8f7c6200647ac3fb187b1990eb50 /src/CMakeLists.txt
parente97d8f3cd405970c74d44b0ded87b1954fe0f2ba (diff)
Include GNUInstallDirs in src/CMakeLists.txt
Fixes installation error under some CMake versions, notably kalakris' CMake backport often used with Travis.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 148cf78..d5a1936 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -2,6 +2,8 @@ if(${CMAKE_VERSION} VERSION_GREATER "3.3")
cmake_policy(SET CMP0063 NEW)
endif()
+include(GNUInstallDirs)
+
set(LIBRARY "libcmark")
set(STATICLIBRARY "libcmark_static")
set(HEADERS