summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-11-17 23:07:30 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-11-17 23:07:30 -0800
commit5ba0fc09583fd85ef13df60130020f75ae846f94 (patch)
tree38449f34b9c876887c0c347cc87bd9db70d126e9 /src/CMakeLists.txt
parenta6c0a1e8b3d2f3456972dad61a435684cac52cb5 (diff)
Set CMARK_DEBUG_NODES for debug builds.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 931c5df..dbe53a5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -63,6 +63,9 @@ add_compiler_export_flags()
set_target_properties(${PROGRAM} PROPERTIES
COMPILE_FLAGS -DCMARK_STATIC_DEFINE)
+# Check integrity of node structure when compiled as debug:
+set(CMAKE_C_FLAGS_DEBUG "-DCMARK_DEBUG_NODES")
+
if (${CMAKE_MAJOR_VERSION} GREATER 1 AND ${CMAKE_MINOR_VERSION} GREATER 8)
set(CMAKE_C_VISIBILITY_PRESET hidden)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)