summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-05-29 10:36:34 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-05-29 10:36:34 -0700
commit678bdab4a4421e64f7c36991a098ae6db730140b (patch)
tree4f038a9225a7c998bcb0415cbfcb5cfd125499c2 /src/CMakeLists.txt
parentb4599a48694b78a5db144f17c2ab281a6d9f17d1 (diff)
Ubsan: add -fsanitize=undefined to link flags too.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f27186e..a38393c 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -167,4 +167,5 @@ endif($ENV{TIMER})
if(CMAKE_BUILD_TYPE STREQUAL "Ubsan")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fsanitize=undefined")
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fsanitize=undefined")
endif() \ No newline at end of file