summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-12-29 22:15:09 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-12-29 22:16:11 -0800
commit86fda06897ccd4d610410f920923c6e1f3e2bf3d (patch)
tree980d5b11b914223de03e1688503d40f9b4acbbec /src/CMakeLists.txt
parentd943eed9db668bb3399264d5c978e20882bc6098 (diff)
Added cmark_ctype.h with locale-independent isspace, ispunct, etc.
Otherwise cmark's behavior varies unpredictably with the locale. `is_punctuation` in utf8.h has also been adjusted so that everything that counts all ASCII symbol characters count as punctuation, even though some are not in P* character classes.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 4272234..87651bc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -15,6 +15,7 @@ set(HEADERS
inlines.h
html_unescape.h
houdini.h
+ cmark_ctype.h
)
set(LIBRARY_SOURCES
cmark.c
@@ -34,6 +35,7 @@ set(LIBRARY_SOURCES
houdini_href_e.c
houdini_html_e.c
houdini_html_u.c
+ cmark_ctype.c
${HEADERS}
)