summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2017-11-14 14:42:06 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2017-11-14 14:42:06 +0100
commit9ead98df8ae2a64842dd157485b69756b5a32a2c (patch)
tree3218608148b660cd377b560047850951fe0ca33b /src/CMakeLists.txt
parent0378b315751c83690121936771f591612ec4e810 (diff)
Generate export header for static-only build
Fixes issue #247.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d5a1936..995a9df 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -115,6 +115,11 @@ if (CMARK_STATIC)
VERSION ${PROJECT_VERSION})
endif(MSVC)
+ if (NOT CMARK_SHARED)
+ generate_export_header(${STATICLIBRARY}
+ BASE_NAME ${PROJECT_NAME})
+ endif()
+
list(APPEND CMARK_INSTALL ${STATICLIBRARY})
endif()