summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt28
1 files changed, 2 insertions, 26 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a16f82..be75c5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,33 +14,9 @@ set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_
add_subdirectory(src)
add_subdirectory(api_test)
-
-if(UNIX)
- INSTALL(FILES man/man1/cmark.1 DESTINATION share/man/man1)
- INSTALL(FILES man/man3/cmark.3 DESTINATION share/man/man3)
-endif(UNIX)
-
+add_subdirectory(man)
enable_testing()
-
-# To get verbose output: cmake --build build --target "test" -- ARGS='-V'
-add_test(spectest_library
- python "${CMAKE_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec"
- "${CMAKE_SOURCE_DIR}/spec.txt" "--library-dir" "${CMAKE_BINARY_DIR}/src"
-)
-add_test(pathological_tests_library
- python "${CMAKE_SOURCE_DIR}/pathological_tests.py"
- "--library-dir" "${CMAKE_BINARY_DIR}/src"
-)
-add_test(NAME api_test COMMAND api_test)
-if (WIN32)
- file(TO_NATIVE_PATH ${CMAKE_BINARY_DIR}/src WIN_DLL_DIR)
- set_tests_properties(api_test PROPERTIES
- ENVIRONMENT "PATH=${WIN_DLL_DIR};$ENV{PATH}"
- )
-endif(WIN32)
-add_test(spectest_executable
- python "${CMAKE_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec" "${CMAKE_SOURCE_DIR}/spec.txt" "--program" "${CMAKE_BINARY_DIR}/src/cmark"
-)
+add_subdirectory(test)
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release" CACHE STRING