summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 203e5bf..100bf28 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,5 @@
-set(PROGRAM_stmd "stmd")
-set(PROGRAM_stmd_SOURCES blocks.c
+set(PROGRAM_cmark "cmark")
+set(PROGRAM_cmark_SOURCES blocks.c
inlines.c
main.c
debug.h
@@ -8,7 +8,7 @@ set(PROGRAM_stmd_SOURCES blocks.c
scanners.h
scanners.c
scanners.re
- stmd.h
+ cmark.h
utf8.h utf8.c
buffer.h buffer.c
references.h references.c
@@ -34,16 +34,16 @@ else(MSVC)
COMMAND ${RE2C} --case-insensitive -b -i ${CMAKE_CURRENT_SOURCE_DIR}/scanners.re >${CMAKE_CURRENT_SOURCE_DIR}/scanners.c)
endif(MSVC)
-add_executable(${PROGRAM_stmd}
- ${PROGRAM_stmd_SOURCES})
+add_executable(${PROGRAM_cmark}
+ ${PROGRAM_cmark_SOURCES})
if (MSVC)
-set_property(TARGET ${PROGRAM_stmd}
+set_property(TARGET ${PROGRAM_cmark}
APPEND PROPERTY LINK_FLAGS /INCREMENTAL:NO)
# if sometimes libs are needed ...
#target_link_libraries(${PROGRAM_chronolog})
endif(MSVC)
-install(TARGETS ${PROGRAM_stmd}
+install(TARGETS ${PROGRAM_cmark}
RUNTIME DESTINATION bin
BUNDLE DESTINATION /Applications)