summaryrefslogtreecommitdiff
path: root/debian/patches/use-cmake-as-buildsystem-debian-extras.patch
diff options
context:
space:
mode:
authorKatolaZ <katolaz@freaknet.org>2019-02-08 05:14:29 +0000
committerKatolaZ <katolaz@freaknet.org>2019-02-08 05:14:29 +0000
commit9696842a61b6608f10633a984732a145c4fe5c68 (patch)
treec715b7439c3bb1d5d5eb09540952da6adc62a0d3 /debian/patches/use-cmake-as-buildsystem-debian-extras.patch
parent172540a4a29fa4c0c5f0431bb5bf5b3d08ec92c0 (diff)
add debian/ folder
Diffstat (limited to 'debian/patches/use-cmake-as-buildsystem-debian-extras.patch')
-rw-r--r--debian/patches/use-cmake-as-buildsystem-debian-extras.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/debian/patches/use-cmake-as-buildsystem-debian-extras.patch b/debian/patches/use-cmake-as-buildsystem-debian-extras.patch
new file mode 100644
index 0000000..0d6dfd9
--- /dev/null
+++ b/debian/patches/use-cmake-as-buildsystem-debian-extras.patch
@@ -0,0 +1,29 @@
+Description: Debian-specific changes to the cmake build system
+Author: Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
+Forwarded: not-needed
+Last-Update: 2018-11-25
+
+--- a/finger/CMakeLists.txt
++++ b/finger/CMakeLists.txt
+@@ -1,4 +1,9 @@
+
++set(
++ CMAKE_C_FLAGS
++ "${CMAKE_C_FLAGS} -D_GNU_SOURCE"
++)
++
+ add_executable(
+ finger
+ finger.c
+--- a/fingerd/CMakeLists.txt
++++ b/fingerd/CMakeLists.txt
+@@ -1,4 +1,9 @@
+
++set(
++ CMAKE_C_FLAGS
++ "${CMAKE_C_FLAGS} -D_GNU_SOURCE"
++)
++
+ add_executable(
+ in.fingerd
+ fingerd.c