summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Wojniak <kainjow@kainjow.com>2015-08-11 10:30:39 -0700
committerKevin Wojniak <kainjow@kainjow.com>2015-08-11 10:30:39 -0700
commit0209706acc088e84e2655747d7dff6d6a4e69b91 (patch)
treea02be24c78ad58d301f64d68f24fbd2f3862d023 /CMakeLists.txt
parentf1b1e2ec71f50a00850db3a68c421a2d79bba115 (diff)
Add option to disable tests
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-x[-rw-r--r--]CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a58f105..7a22064 100644..100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,11 +13,17 @@ set(PROJECT_VERSION_MINOR 21)
set(PROJECT_VERSION_PATCH 0)
set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH} )
+option(CMARK_TESTS "Build cmark tests and enable testing" ON)
+
add_subdirectory(src)
-add_subdirectory(api_test)
+if(CMARK_TESTS)
+ add_subdirectory(api_test)
+endif()
add_subdirectory(man)
-enable_testing()
-add_subdirectory(test testdir)
+if(CMARK_TESTS)
+ enable_testing()
+ add_subdirectory(test testdir)
+endif()
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release" CACHE STRING