summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGulliver <gulliver@fargonauten.de>2014-09-10 17:24:27 +0200
committerGulliver <gulliver@fargonauten.de>2014-09-10 17:24:27 +0200
commit0a40eea051e5b61c954f32025df21a475b0ee111 (patch)
treea3207fbe7c62a6bd0b5659bd6a9d5109b53b1e64 /CMakeLists.txt
parent358925ec028bcdb312616ffebf427eda595896cd (diff)
added scanner.c to sources and special rule
for it to build it from scanner.re (added setting RE2C which contains the path to needed re2c utilitity)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ae057c2..905e17d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,6 +14,7 @@ CHECK_INCLUDE_FILE (stdbool.h HAVE_STDBOOL_H)
#option(${PROJECT_NAME}_WITH_DOCS "generate Documentation" OFF)
#option(${PROJECT_NAME}_WITH_TESTS "enable testing" ON)
option(CMAKE_SUPPRESS_REGENERATION "suppress rules to re-run cmake on changes (warning: no dependency checks!)?" OFF)
+set(RE2C ${CMAKE_CURRENT_SOURCE_DIR}/re2c)
if (MSVC)
option(PROJECT_LINK_MSVC_MT "link with /MT instead of /MD (use msvc runtime dlls versus static linked)" ON)