summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGulliver <gulliver@fargonauten.de>2014-09-11 18:50:40 +0200
committerGulliver <gulliver@fargonauten.de>2014-09-11 18:50:40 +0200
commit0e52758e8ec75b71e58ad1bf9b4c40c014b08c58 (patch)
treeb9b3066610c2f49745b22ee0172cbf59381cdc99 /CMakeLists.txt
parent0a8ab28bed8cef7ff594fd7ab15bd4d300c0fee2 (diff)
parent63b41dd05b1fcbef10d41e28cef1645ee8b6642d (diff)
Merge branch 'cmake-build' of https://github.com/gittiver/stmd into cmake-build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 905e17d..491645c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,11 @@ CHECK_INCLUDE_FILE (stdbool.h HAVE_STDBOOL_H)
#option(${PROJECT_NAME}_WITH_DOCS "generate Documentation" OFF)
#option(${PROJECT_NAME}_WITH_TESTS "enable testing" ON)
option(CMAKE_SUPPRESS_REGENERATION "suppress rules to re-run cmake on changes (warning: no dependency checks!)?" OFF)
-set(RE2C ${CMAKE_CURRENT_SOURCE_DIR}/re2c)
+if (MSVC)
+ set(RE2C ${CMAKE_CURRENT_SOURCE_DIR}/re2c)
+else(MSVC)
+ set(RE2C re2c)
+endif(MSVC)
if (MSVC)
option(PROJECT_LINK_MSVC_MT "link with /MT instead of /MD (use msvc runtime dlls versus static linked)" ON)