summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-02-19 10:34:34 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2015-02-19 10:34:34 -0800
commit0fdb06f275aeb67331fd0984d89227ecadeeb26e (patch)
treefdcaf6282122fc3e021b6faf475479af5f1a6277 /CMakeLists.txt
parentaad831e87c92530fe54b7dcdda593c53ccc3f0b6 (diff)
Added 'Asan' build type.
`make asan` will link against ASan; the resulting executable will do checks for memory access issues. Thanks @JordanMilne for the suggestion.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f681698..db04698 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,6 @@
project(cmark)
cmake_minimum_required(VERSION 2.8.9)
+include("FindAsan.cmake")
if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
message(FATAL_ERROR "Do not build in-source.\nPlease remove CMakeCache.txt and the CMakeFiles/ directory.\nThen: mkdir build ; cd build ; cmake .. ; make")