summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Müller <git@foonathan.net>2019-03-18 12:13:52 +0100
committerJonathan Müller <git@foonathan.net>2019-03-18 12:13:52 +0100
commit11043696474263edbd508b98076933b81ad32805 (patch)
treefe15e9183c10dfd326ca76a3f98f1d3933bc530c /CMakeLists.txt
parent325a1471d2a32bcc1e2d2580b973ff4ba1df85e8 (diff)
Bump CMake to version 3
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt18
1 files changed, 2 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a25b269..4c438b6 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,12 +1,5 @@
-cmake_minimum_required(VERSION 2.8.9)
-
-# prevent ugly developer warnings because version is set directly, not through project()
-# it should be redone properly by using VERSION in project() if on CMake 3.x
-if(CMAKE_MAJOR_VERSION GREATER 2)
- cmake_policy(SET CMP0048 OLD)
-endif()
-
-project(cmark)
+cmake_minimum_required(VERSION 3.0)
+project(cmark VERSION 0.28.3)
include("FindAsan.cmake")
@@ -14,13 +7,6 @@ if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
message(FATAL_ERROR "Do not build in-source.\nPlease remove CMakeCache.txt and the CMakeFiles/ directory.\nThen: mkdir build ; cd build ; cmake .. ; make")
endif()
-set(PROJECT_NAME "cmark")
-
-set(PROJECT_VERSION_MAJOR 0)
-set(PROJECT_VERSION_MINOR 28)
-set(PROJECT_VERSION_PATCH 3)
-set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH} )
-
option(CMARK_TESTS "Build cmark tests and enable testing" ON)
option(CMARK_STATIC "Build static libcmark library" ON)
option(CMARK_SHARED "Build shared libcmark library" ON)