summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-01-06 13:55:01 +0100
committerGitHub <noreply@github.com>2017-01-06 13:55:01 +0100
commit3894dbddbf4142748bc0dd72c5460b860dd8b5ef (patch)
tree681a8b3b3b6b57cf67c223eee61716b94df732ff /CMakeLists.txt
parentc786cacc291418d68b52636f951af778fefa214f (diff)
parentc9c18fff2fd8b3d0bef0120fe3db3b6ab0beeb9b (diff)
Merge pull request #179 from winterheart/cmake
CMake impovement
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 328f74c..4e60fd5 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,9 +22,11 @@ set(PROJECT_VERSION_PATCH 1)
set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH} )
option(CMARK_TESTS "Build cmark tests and enable testing" ON)
+option(CMARK_STATIC "Build static libcmark library" ON)
+option(CMARK_SHARED "Build shared libcmark library" ON)
add_subdirectory(src)
-if(CMARK_TESTS)
+if(CMARK_TESTS AND CMARK_SHARED)
add_subdirectory(api_test)
endif()
add_subdirectory(man)