summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2019-12-22 11:17:48 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2020-01-02 22:58:05 -0700
commit3cad10545eca566bcf6c2bc3b5dd8b577a70493d (patch)
tree2b90eb85362aa2d8d01344a626d66e9b4d63e9b3 /CMakeLists.txt
parent828eeaf8960a347777f34ed134c5211717f1d446 (diff)
build: use `CMAKE_INCLUDE_CURRENT_DIRECTORY`
This uses the CMake mechanism for including the current source and binary directories. This avoids the custom handling for this.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4b8d98..9f5a8dd 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,8 @@ endif()
set(CMAKE_C_VISIBILITY_PRESET hidden)
set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
# The Linux modules distributed with CMake add "-rdynamic" to the build flags
# which is incompatible with static linking under certain configurations.
# Unsetting CMAKE_SHARED_LIBRARY_LINK_C_FLAGS ensures this does not happen.