summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <fiddlosopher@gmail.com>2014-11-10 13:45:16 -0800
committerJohn MacFarlane <fiddlosopher@gmail.com>2014-11-10 13:45:16 -0800
commit500c62bd380e52e13972f4c2971346d9ab1e63ed (patch)
tree2cb1d458d752e9e8a92f65b03e2892028a72d507 /CMakeLists.txt
parent1e1a96d7607ac77759070dcac5e0cb2b72c4ddaa (diff)
Properly set default build type in CMakeLists.txt.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 350aeae..44c125a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,7 +14,10 @@ set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_
add_subdirectory(src)
-set(CMAKE_BUILD_TYPE Release)
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE "Release" CACHE STRING
+ "Choose the type of build, options are: Debug Release." FORCE)
+endif(NOT CMAKE_BUILD_TYPE)
set(CPACK_GENERATOR TGZ ZIP)
if(WIN32 AND NOT CYGWIN)