summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2017-11-18 16:08:55 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2017-11-18 16:16:01 +0100
commit772c4cbde52f1f295f66bb80a55d3db446742094 (patch)
treebd9c7a8837538412f99877147c4d3e11d61ac2e6 /CMakeLists.txt
parent736d8a3d81ab2ac8e5556f2dd5f6fed9d9137d18 (diff)
Also run API tests with CMARK_SHARED=OFF
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4eb0541..a25b269 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ option(CMARK_SHARED "Build shared libcmark library" ON)
option(CMARK_LIB_FUZZER "Build libFuzzer fuzzing harness" OFF)
add_subdirectory(src)
-if(CMARK_TESTS AND CMARK_SHARED)
+if(CMARK_TESTS AND (CMARK_SHARED OR CMARK_STATIC))
add_subdirectory(api_test)
endif()
add_subdirectory(man)