summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2014-11-24 21:09:53 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2014-11-24 21:09:53 +0100
commit79ea99b9eb6c3ae8f40cf52da0c0dd2b998d6bf4 (patch)
treee880caaaa7a9bd236aa12dfa0b6ea468ed0b643e /CMakeLists.txt
parentf222b8e2ef1ffcd18c6093cd1272fd9e8b757291 (diff)
Set test environment on Windows
Add directory containing cmark.dll to PATH on Windows.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb1944b..e554266 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,12 @@ add_test(spectest_library
"${CMAKE_SOURCE_DIR}/spec.txt" "--library-dir" "${CMAKE_BINARY_DIR}/src"
)
add_test(NAME api_test COMMAND api_test)
+if (WIN32)
+ file(TO_NATIVE_PATH ${CMAKE_BINARY_DIR}/src WIN_DLL_DIR)
+ set_tests_properties(api_test PROPERTIES
+ ENVIRONMENT "PATH=${WIN_DLL_DIR};$ENV{PATH}"
+ )
+endif(WIN32)
add_test(spectest_executable
python "${CMAKE_SOURCE_DIR}/runtests.py" "--no-normalize" "--spec" "${CMAKE_SOURCE_DIR}/spec.txt" "--program" "${CMAKE_BINARY_DIR}/src/cmark"
)