summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2014-11-18 18:37:56 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2014-11-18 18:43:04 +0100
commit8dba3f7f3591f4271522835cb2057acf4ae56f53 (patch)
tree8bf044f7c0fa0e13925db0c64e8720a86c0b2336 /CMakeLists.txt
parent3f9fec6998fccabe5d61bfe84b9d2431f9d5ae53 (diff)
Start with tests for the C API
The C API tests can be run individually via build/api_test/api_test Or together with the spec tests via cmake --build build --target test
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 105c257..9e2adbd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ set(PROJECT_VERSION_PATCH 1)
set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH} )
add_subdirectory(src)
+add_subdirectory(api_test)
if(UNIX)
INSTALL(FILES man/man1/cmark.1 DESTINATION share/man/man1)
@@ -24,6 +25,7 @@ enable_testing()
add_test(spectest
perl "${CMAKE_SOURCE_DIR}/runtests.pl" "${CMAKE_SOURCE_DIR}/spec.txt" "${CMAKE_BINARY_DIR}/src/cmark"
)
+add_test(NAME api_test COMMAND api_test)
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release" CACHE STRING