summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2017-11-18 11:18:17 -0800
committerGitHub <noreply@github.com>2017-11-18 11:18:17 -0800
commit9f279be995da5f15a9a988fe93dc983401c28d95 (patch)
treefa40415766fdf1d2dc35f0814139ccad61515f72 /CMakeLists.txt
parentdb63ea9a07135568c44d537a9f2e999b210f0b9f (diff)
parent9253cbff4f28651ec31ed1e1e714c9093a1ac222 (diff)
Merge pull request #250 from nwellnhof/test-static-only-build
Test static-only build
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4eb0541..a25b269 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,7 @@ option(CMARK_SHARED "Build shared libcmark library" ON)
option(CMARK_LIB_FUZZER "Build libFuzzer fuzzing harness" OFF)
add_subdirectory(src)
-if(CMARK_TESTS AND CMARK_SHARED)
+if(CMARK_TESTS AND (CMARK_SHARED OR CMARK_STATIC))
add_subdirectory(api_test)
endif()
add_subdirectory(man)