summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Müller <jonathanmueller.dev@gmail.com>2016-06-27 19:54:25 +0200
committerJonathan Müller <jonathanmueller.dev@gmail.com>2016-06-27 19:54:25 +0200
commit9fe857d827b1fdb585e12d8387c3cb5fb5392c61 (patch)
tree301879117aa95ab6c75ae9cc148168cb20a3a992 /CMakeLists.txt
parent2b1b00fb19fe470f7745c208377345975b9e0b2c (diff)
Export the targets on installation
This allows using them in other cmake projects.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ab6a72..52f8b4b 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,3 +29,6 @@ if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release" CACHE STRING
"Choose the type of build, options are: Debug Profile Release Asan Ubsan." FORCE)
endif(NOT CMAKE_BUILD_TYPE)
+
+# export targets
+install(EXPORT cmark DESTINATION lib/cmake)