summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-05-29 10:15:29 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-05-29 10:15:29 -0700
commitb4599a48694b78a5db144f17c2ab281a6d9f17d1 (patch)
tree44196cf7204aade8acfce11f76551be0831e3923 /CMakeLists.txt
parent8f429810c03f1d869936776b174332d55ff88bde (diff)
Added Ubsan build target, to check for undefined behavior.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9a6f304..a4ebe92 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,5 +21,5 @@ add_subdirectory(test testdir)
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release" CACHE STRING
- "Choose the type of build, options are: Debug Profile Release." FORCE)
+ "Choose the type of build, options are: Debug Profile Release Asan Ubsan." FORCE)
endif(NOT CMAKE_BUILD_TYPE)