summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2019-12-22 10:29:46 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2020-01-02 22:58:05 -0700
commitb7188e8c1bfe0e148c3d3e6d08a9004cdfb2264d (patch)
treede322e24e4ffb17a783b14fada8f0bfb0f1304a5 /CMakeLists.txt
parent78168bfef1fa508b5c37220d068d8835184a0404 (diff)
build: only include GNUInstallDirs once
Avoid including the utility once, which should avoid some unnecessary CMake checks, and reduces duplication.
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7e44a5a..f375289 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,7 @@ cmake_minimum_required(VERSION 3.0)
project(cmark VERSION 0.29.0)
include("FindAsan.cmake")
+include(GNUInstallDirs)
if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
message(FATAL_ERROR "Do not build in-source.\nPlease remove CMakeCache.txt and the CMakeFiles/ directory.\nThen: mkdir build ; cd build ; cmake .. ; make")