summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-11-24 21:34:19 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-11-24 21:34:19 -0800
commitbe834300a31ffac837b6434650c206aa8e292e1b (patch)
treec6353469918635bd2a08b1c8b83074f8e3a67b00 /CMakeLists.txt
parent6bd809b6b4836e1026998c2d4c1fc76506de3e8f (diff)
parent9de6890f11cf6d1947132bbf90e3735aabb0a683 (diff)
Merge pull request #218 from nwellnhof/windows_fixes
Windows fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb1944b..e554266 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,12 @@ add_test(spectest_library
"${CMAKE_SOURCE_DIR}/spec.txt" "--library-dir" "${CMAKE_BINARY_DIR}/src"
)
add_test(NAME api_test COMMAND api_test)
+if (WIN32)
+ file(TO_NATIVE_PATH ${CMAKE_BINARY_DIR}/src WIN_DLL_DIR)
+ set_tests_properties(api_test PROPERTIES
+ ENVIRONMENT "PATH=${WIN_DLL_DIR};$ENV{PATH}"
+ )
+endif(WIN32)
add_test(spectest_executable
python "${CMAKE_SOURCE_DIR}/runtests.py" "--no-normalize" "--spec" "${CMAKE_SOURCE_DIR}/spec.txt" "--program" "${CMAKE_BINARY_DIR}/src/cmark"
)