summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-11-29 11:00:48 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-11-29 11:00:48 -0800
commitc301f6b6c6c3c870bc7a56334c3fd1d42356b736 (patch)
treef2a4919d4086ea504075595fb9427041ddbf4b5a /CMakeLists.txt
parent23cc43d2e77afd949a0951f97539fd63d50c3cee (diff)
Moved testing programs to test/.
Added test/CMakeLists.txt.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 1 insertions, 21 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2e4c870..be75c5e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,28 +15,8 @@ set(PROJECT_VERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_
add_subdirectory(src)
add_subdirectory(api_test)
add_subdirectory(man)
-
enable_testing()
-
-# To get verbose output: cmake --build build --target "test" -- ARGS='-V'
-add_test(spectest_library
- python "${CMAKE_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec"
- "${CMAKE_SOURCE_DIR}/spec.txt" "--library-dir" "${CMAKE_BINARY_DIR}/src"
-)
-add_test(pathological_tests_library
- python "${CMAKE_SOURCE_DIR}/pathological_tests.py"
- "--library-dir" "${CMAKE_BINARY_DIR}/src"
-)
-add_test(NAME api_test COMMAND api_test)
-if (WIN32)
- file(TO_NATIVE_PATH ${CMAKE_BINARY_DIR}/src WIN_DLL_DIR)
- set_tests_properties(api_test PROPERTIES
- ENVIRONMENT "PATH=${WIN_DLL_DIR};$ENV{PATH}"
- )
-endif(WIN32)
-add_test(spectest_executable
- python "${CMAKE_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec" "${CMAKE_SOURCE_DIR}/spec.txt" "--program" "${CMAKE_BINARY_DIR}/src/cmark"
-)
+add_subdirectory(test)
if(NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release" CACHE STRING