summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-11-27 12:23:47 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-11-27 12:25:20 -0800
commitf320d9f9ea2f983d9a0f5d01f1235eef1df28f37 (patch)
treeae4c04f75e82d293609b865c255dcc03fdf1003f /CMakeLists.txt
parentab37be988c414646fa4813af9cf1ee0823a436fe (diff)
Added pathological_tests.py to test suite.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e554266..2eb9815 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,10 @@ add_test(spectest_library
python "${CMAKE_SOURCE_DIR}/runtests.py" "--no-normalize" "--spec"
"${CMAKE_SOURCE_DIR}/spec.txt" "--library-dir" "${CMAKE_BINARY_DIR}/src"
)
+add_test(pathological_tests_library
+ python "${CMAKE_SOURCE_DIR}/pathological_tests.py"
+ "--library-dir" "${CMAKE_BINARY_DIR}/src"
+)
add_test(NAME api_test COMMAND api_test)
if (WIN32)
file(TO_NATIVE_PATH ${CMAKE_BINARY_DIR}/src WIN_DLL_DIR)