summaryrefslogtreecommitdiff
path: root/api_test/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2014-11-18 21:34:29 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2014-11-18 21:34:29 +0100
commitfc46123f0a527a364f9a0fb1e7b8b7448fd84b89 (patch)
tree6d1db93c6c78486cab4c7ebaa6a75ba7c0658090 /api_test/CMakeLists.txt
parent00a48356ee002a63362496ca62c1fa8f6c05ad58 (diff)
Set compiler flags for api_test
Diffstat (limited to 'api_test/CMakeLists.txt')
-rw-r--r--api_test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/api_test/CMakeLists.txt b/api_test/CMakeLists.txt
index 66629d8..b2ab2c8 100644
--- a/api_test/CMakeLists.txt
+++ b/api_test/CMakeLists.txt
@@ -9,3 +9,11 @@ include_directories(
)
target_link_libraries(api_test libcmark)
+# Compiler flags
+if(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_C_COMPILER_ID}" STREQUAL "Clang")
+ set_target_properties(api_test PROPERTIES COMPILE_FLAGS
+ "-std=c99 -Wall -Wextra"
+ )
+elseif ("${CMAKE_C_COMPILER_ID}" STREQUAL "MSVC")
+ set_target_properties(api_test PROPERTIES COMPILE_FLAGS "/TP /W4")
+endif()