summaryrefslogtreecommitdiff
path: root/man/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-01-11 10:46:51 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2015-01-11 10:48:59 -0800
commit9b66bdd02b4ca18f9b48b8903599bbdef4dd599a (patch)
treea1e30614f15898801e98b000b608b94dc1bfe381 /man/CMakeLists.txt
parentd44720f4c775fd3f83adb30741e202f40581f097 (diff)
Added cmark.3 man page to repository and archive.
It simplifies the build if python and the cmark library aren't needed to build the man page. The top level Makefile has a rule to regenerate this when src/cmark.h changes. Updated Makefile.nmake for recent changes. Added case folding data file to archive, since otherwise make fails.
Diffstat (limited to 'man/CMakeLists.txt')
-rw-r--r--man/CMakeLists.txt32
1 files changed, 4 insertions, 28 deletions
diff --git a/man/CMakeLists.txt b/man/CMakeLists.txt
index 1540812..443996e 100644
--- a/man/CMakeLists.txt
+++ b/man/CMakeLists.txt
@@ -1,32 +1,8 @@
if (NOT MSVC)
- set(PYTHON python)
- set(LIBRARY "libcmark")
-
- add_custom_target(man ALL
- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/cmark.3
- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/cmark.1
- )
-
- add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/cmark.3
- DEPENDS ${CMAKE_SOURCE_DIR}/src/cmark.h
- DEPENDS ${LIBRARY}
- COMMAND ${PYTHON} ${CMAKE_CURRENT_SOURCE_DIR}/make_man_page.py
- ${CMAKE_SOURCE_DIR}/src/cmark.h >
- ${CMAKE_CURRENT_BINARY_DIR}/cmark.3
- )
-
- add_custom_command(
- OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/cmark.1
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/man1/cmark.1
- COMMAND cp
- ${CMAKE_CURRENT_SOURCE_DIR}/man1/cmark.1
- ${CMAKE_CURRENT_BINARY_DIR}/cmark.1
- )
-
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cmark.1
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man1/cmark.1
DESTINATION share/man/man1)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/cmark.3
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man3/cmark.3
DESTINATION share/man/man3)
-endif(NOT MSVC) \ No newline at end of file
+endif(NOT MSVC)
+