summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2015-04-26 21:36:34 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2015-04-26 21:36:34 +0200
commit141fb056c7a95ce12ed845a24bdf3f9af66afdfb (patch)
treeedb3d610f7cd914da3d5cd5866a3508cd9de7dbf /src/CMakeLists.txt
parent153149fb94b3dfe63e8960a457311521ecf302c8 (diff)
Compile static library with -DCMARK_STATIC_DEFINE
Fixes warnings on Windows.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 594d76e..894b2c1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -87,6 +87,8 @@ set_target_properties(${LIBRARY} PROPERTIES
OUTPUT_NAME "cmark"
SOVERSION ${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}
VERSION ${PROJECT_VERSION})
+set_target_properties(${STATICLIBRARY} PROPERTIES
+ COMPILE_FLAGS -DCMARK_STATIC_DEFINE)
if (MSVC)
set_target_properties(${STATICLIBRARY} PROPERTIES