summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-06-16 09:54:31 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-06-16 12:59:47 -0700
commit208c794def61eb819ed6eebe1d51867613addce0 (patch)
tree0d0f81dab960befc5efa7124ae900ddd64e43be3 /src/CMakeLists.txt
parentf904f701cf4390b4d5531c5626c5cf08d85a913f (diff)
Replace gperf-based entity lookup with binary tree lookup.
The primary advantage is a big reduction in the size of the compiled library and executable (> 100K). There should be no measurable performance difference in normal documents. I detected a slight performance hit (around 5%) in a file containing 1,000,000 entities. * Removed `src/html_unescape.gperf` and `src/html_unescape.h`. * Added `src/entities.h` (generated by `tools/make_entities_h.py`). * Added binary tree lookup functions to `houdini_html_u.c`, and use the data in `src/entities.h`.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 716b97b..06de9ef 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,9 +14,9 @@ set(HEADERS
utf8.h
scanners.h
inlines.h
- html_unescape.h
houdini.h
cmark_ctype.h
+ entities.h
)
set(LIBRARY_SOURCES
cmark.c
@@ -33,7 +33,6 @@ set(LIBRARY_SOURCES
xml.c
html.c
commonmark.c
- html_unescape.gperf
houdini_href_e.c
houdini_html_e.c
houdini_html_u.c