summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2015-07-25 16:11:19 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2015-07-25 16:11:19 -0700
commit2a9409f587eec1acd7a98cbd5dacc31ac3525812 (patch)
treec791ea8465e2af2a32bd6c98745d72ca0588d08a /src/CMakeLists.txt
parentb018c01fad3b0c6dd9c180b3ba804baee326d9dd (diff)
Removed cmark_strbuf_printf and cmark_strbuf_vprintf.
These are no longer needed, and cause complications for MSVC. Also removed HAVE_VA_COPY and HAVE_C99_SNPRINTF feature tests.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b40c1ac..80ecfc2 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -139,11 +139,6 @@ CHECK_C_SOURCE_COMPILES("
int f(void) __attribute__ (());
int main() { return 0; }
" HAVE___ATTRIBUTE__)
-CHECK_C_SOURCE_RUNS("
- #include <stdio.h>
- int main() { return snprintf(NULL, 0, \"123\") == 3 ? 0 : 1; }
-" HAVE_C99_SNPRINTF)
-CHECK_SYMBOL_EXISTS(va_copy stdarg.h HAVE_VA_COPY)
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/config.h.in