summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGulliver <gulliver@fargonauten.de>2014-09-10 14:08:44 +0200
committerGulliver <gulliver@fargonauten.de>2014-09-10 14:08:44 +0200
commit358925ec028bcdb312616ffebf427eda595896cd (patch)
tree142ca7a96eef0f3bc95a3d165292563a55b9d852 /src/CMakeLists.txt
parent81de8a753da76566a52a1c8dd80e4d3784e78567 (diff)
added initial version of cmake build-files
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..c454eca
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,34 @@
+set(PROGRAM_stmd "stmd")
+set(PROGRAM_stmd_SOURCES blocks.c
+inlines.c
+main.c
+debug.h
+detab.c
+bstrlib.c
+bstrlib.h
+getopt.c
+html.c
+
+
+print.c
+scanners.h
+scanners.re
+stmd.h
+utf8.c
+utf8.h
+uthash.h
+)
+
+add_executable(${PROGRAM_stmd}
+ ${PROGRAM_stmd_SOURCES})
+
+if (MSVC)
+set_property(TARGET ${PROGRAM_chronolog}
+ APPEND PROPERTY LINK_FLAGS /INCREMENTAL:NO)
+target_link_libraries(${PROGRAM_chronolog} gdiplus.lib)
+endif(MSVC)
+install(TARGETS ${PROGRAM_chronolog}
+RUNTIME DESTINATION bin
+BUNDLE DESTINATION Applications)
+
+