summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2019-12-22 11:17:48 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2020-01-02 22:58:05 -0700
commit3cad10545eca566bcf6c2bc3b5dd8b577a70493d (patch)
tree2b90eb85362aa2d8d01344a626d66e9b4d63e9b3 /src/CMakeLists.txt
parent828eeaf8960a347777f34ed134c5211717f1d446 (diff)
build: use `CMAKE_INCLUDE_CURRENT_DIRECTORY`
This uses the CMake mechanism for including the current source and binary directories. This avoids the custom handling for this.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9b7b4dd..d864f59 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -46,8 +46,6 @@ set(LIBRARY_SOURCES
set(PROGRAM "cmark")
set(PROGRAM_SOURCES main.c)
-include_directories(. ${CMAKE_CURRENT_BINARY_DIR})
-
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/cmark_version.h.in
${CMAKE_CURRENT_BINARY_DIR}/cmark_version.h)