summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-11-14 15:49:35 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-11-14 15:49:35 -0800
commit694fa11266741aa061477aaca627e0445ba20723 (patch)
tree6107d6f018ad6bd9a63dfa992e765255d44c6f8b /src/CMakeLists.txt
parentbfbda17036768e6793aeebe666141003e3afb014 (diff)
Disable warnings about inline with mingw.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b81146b..a342d3b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -102,6 +102,10 @@ elseif(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -std=c99 -pedantic")
endif()
+if(CMAKE_COMPILER_IS_MINGW)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -fgnu89-inline")
+endif(CMAKE_COMPILER_IS_MINGW)
+
if($ENV{TIMER})
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTIMER=1")
endif($ENV{TIMER})