summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <fiddlosopher@gmail.com>2014-11-13 11:00:04 -0800
committerJohn MacFarlane <fiddlosopher@gmail.com>2014-11-13 11:00:15 -0800
commit7861d82c6fcfb3f813e642c0f59318eb4f9f5332 (patch)
tree116269e4b4341222530c7acbde6b1b54d3138f4c /src/CMakeLists.txt
parent3c9bdf645958a1c5b71cc9b96a5b711cca14224f (diff)
Added bench.h and inserted timing macros in main.
`make TIMER=1` to build with timings.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 40efdf4..3c0f610 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,6 +7,7 @@ set(HEADERS
chunk.h
references.h
debug.h
+ bench.h
utf8.h
scanners.h
inlines.h
@@ -91,3 +92,6 @@ elseif(CMAKE_COMPILER_IS_GNUCC OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -std=c99 -pedantic")
endif()
+if($ENV{TIMER})
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTIMER=1")
+endif($ENV{TIMER})