summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGulliver <gulliver@fargonauten.de>2014-09-11 20:31:59 +0200
committerGulliver <gulliver@fargonauten.de>2014-09-22 22:48:29 +0200
commit7e0b564af9ea4aaa35feced8c6fda6a97c7f8948 (patch)
treee7af742d230db039683ab752fbce136669c5eccc /src/CMakeLists.txt
parent3e16b871d17f812be1226c23fffbbecbe52876b0 (diff)
using only includes from system
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt95
1 files changed, 50 insertions, 45 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3b8b770..203e5bf 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,45 +1,50 @@
-set(PROGRAM_stmd "stmd")
-set(PROGRAM_stmd_SOURCES blocks.c
- inlines.c
- main.c
- debug.h
- detab.c
- bstrlib.c
- bstrlib.h
- getopt.c
- html.c
- print.c
- scanners.h
- scanners.c
- scanners.re
- stmd.h
- utf8.c
- utf8.h
- uthash.h
-)
-
-if (MSVC)
- file(TO_NATIVE_PATH ${CMAKE_CURRENT_SOURCE_DIR} DOS_CURRENT_SOURCE_DIR)
- add_custom_command( OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/scanners.c
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/scanners.re
- COMMAND ${RE2C} --case-insensitive -b -i ${DOS_CURRENT_SOURCE_DIR}\\scanners.re >${DOS_CURRENT_SOURCE_DIR}\\scanners.c)
-else(MSVC)
- add_custom_command( OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/scanners.c
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/scanners.re
- COMMAND ${RE2C} --case-insensitive -b -i ${CMAKE_CURRENT_SOURCE_DIR}/scanners.re >${CMAKE_CURRENT_SOURCE_DIR}/scanners.c)
-endif(MSVC)
-
-add_executable(${PROGRAM_stmd}
- ${PROGRAM_stmd_SOURCES})
-
-if (MSVC)
-set_property(TARGET ${PROGRAM_stmd}
- APPEND PROPERTY LINK_FLAGS /INCREMENTAL:NO)
-# if sometimes libs are needed ...
-#target_link_libraries(${PROGRAM_chronolog})
-endif(MSVC)
-install(TARGETS ${PROGRAM_stmd}
-RUNTIME DESTINATION bin
-BUNDLE DESTINATION Applications)
-
-
+set(PROGRAM_stmd "stmd")
+set(PROGRAM_stmd_SOURCES blocks.c
+ inlines.c
+ main.c
+ debug.h
+ getopt.c
+ print.c
+ scanners.h
+ scanners.c
+ scanners.re
+ stmd.h
+ utf8.h utf8.c
+ buffer.h buffer.c
+ references.h references.c
+ html/html.c
+ html/html_unescape.h
+ html/html_unescape.gperf
+ html/houdini.h
+ html/houdini_href_e.c
+ html/houdini_html_e.c
+ html/houdini_html_u.c
+)
+
+include_directories(. html)
+
+if (MSVC)
+ file(TO_NATIVE_PATH ${CMAKE_CURRENT_SOURCE_DIR} DOS_CURRENT_SOURCE_DIR)
+ add_custom_command( OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/scanners.c
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/scanners.re
+ COMMAND ${RE2C} --case-insensitive -b -i ${DOS_CURRENT_SOURCE_DIR}\\scanners.re >${DOS_CURRENT_SOURCE_DIR}\\scanners.c)
+else(MSVC)
+ add_custom_command( OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/scanners.c
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/scanners.re
+ COMMAND ${RE2C} --case-insensitive -b -i ${CMAKE_CURRENT_SOURCE_DIR}/scanners.re >${CMAKE_CURRENT_SOURCE_DIR}/scanners.c)
+endif(MSVC)
+
+add_executable(${PROGRAM_stmd}
+ ${PROGRAM_stmd_SOURCES})
+
+if (MSVC)
+set_property(TARGET ${PROGRAM_stmd}
+ APPEND PROPERTY LINK_FLAGS /INCREMENTAL:NO)
+# if sometimes libs are needed ...
+#target_link_libraries(${PROGRAM_chronolog})
+endif(MSVC)
+install(TARGETS ${PROGRAM_stmd}
+RUNTIME DESTINATION bin
+BUNDLE DESTINATION /Applications)
+
+