summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-11-07 10:26:33 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-11-07 10:26:33 -0800
commita137b3ea396213374c25563783337a07bd7e076b (patch)
treeea4c532c6d58b2df399e532d102d96ee8acaf457 /src/CMakeLists.txt
parentc140ea1bc5612233c7ef7063787e3864c08b304a (diff)
Shared library is again libcmark.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index ecd2f8c..401ff08 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 2.8)
-set(LIBRARY "commonmark")
+set(LIBRARY "cmark-shared")
set(HEADERS
cmark.h
buffer.h
@@ -53,6 +53,8 @@ endif(MSVC)
add_executable(${PROGRAM} ${PROGRAM_SOURCES})
add_library(${LIBRARY} SHARED ${LIBRARY_SOURCES})
+set_target_properties(${LIBRARY}
+ PROPERTIES OUTPUT_NAME "cmark")
set_property(TARGET ${LIBRARY}
APPEND PROPERTY MACOSX_RPATH true)