summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <fiddlosopher@gmail.com>2014-12-04 10:49:08 -0800
committerJohn MacFarlane <fiddlosopher@gmail.com>2014-12-04 10:49:08 -0800
commitb2befa48e38a9738c97501e180d1296e3323b4a9 (patch)
tree59db5b80c87b6f2908d3b33cc4a71c636388a5c8 /src/CMakeLists.txt
parentcfb756f918aad3ef7714f75a06210e564ecb90f9 (diff)
Create pkg-config file as part of build procedure.
Closes #234.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e0fc66e..d9af586 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -60,6 +60,11 @@ else(MSVC)
${CMAKE_CURRENT_SOURCE_DIR}/scanners.re )
endif(MSVC)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/libcmark.pc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/libcmark.pc @ONLY)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libcmark.pc
+ DESTINATION lib/pkgconfig)
+
include (GenerateExportHeader)
add_executable(${PROGRAM} ${PROGRAM_SOURCES})