summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2016-05-17 20:39:53 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2016-05-17 20:39:53 +0200
commit6ac50ca5f3edc478a9593f721c8f1b095a5cdb18 (patch)
tree6e861b2525f0f05890b4a04410288213bc3113c6 /test/CMakeLists.txt
parentf8271ed0f523f61dae39b2c9edcda7758af2b84d (diff)
Fix tests under MinGW
- Fix PATH for api_test, see: https://cmake.org/pipermail/cmake/2009-May/029423.html - DLL is named libcmark.dll under MinGW.
Diffstat (limited to 'test/CMakeLists.txt')
-rwxr-xr-xtest/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index fbfd1d0..211bf69 100755
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -13,9 +13,9 @@ add_test(NAME api_test COMMAND api_test)
if (WIN32)
file(TO_NATIVE_PATH ${CMAKE_BINARY_DIR}/src WIN_DLL_DIR)
- set_tests_properties(api_test PROPERTIES
- ENVIRONMENT "PATH=${WIN_DLL_DIR};$ENV{PATH}"
- )
+ set(NEWPATH "${WIN_DLL_DIR};$ENV{PATH}")
+ string(REPLACE ";" "\\;" NEWPATH "${NEWPATH}")
+ set_tests_properties(api_test PROPERTIES ENVIRONMENT "PATH=${NEWPATH}")
set(ROUNDTRIP,"${CMAKE_CURRENT_SOURCE_DIR}/roundtrip.bat")
else(WIN32)
set(ROUNDTRIP,"${CMAKE_CURRENT_SOURCE_DIR}/roundtrip.sh")