summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2016-03-26 16:24:56 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2016-03-28 11:22:58 +0200
commit848ca96890db32eb98d44765886853bed626a4ee (patch)
tree7ac04d30250616a32835c3d2995af5f499c4d9db /test/CMakeLists.txt
parentdf5eed3b7fce2853e331c7de5294668c5b376334 (diff)
Add first regression tests
I think it's a good idea to add tests after fixing bugs. This is really easy using the spec test infrastructure.
Diffstat (limited to 'test/CMakeLists.txt')
-rwxr-xr-xtest/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d537ab5..fbfd1d0 100755
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -53,6 +53,13 @@ IF (PYTHONINTERP_FOUND)
"${ROUNDTRIP} ${CMAKE_CURRENT_BINARY_DIR}/../src/cmark"
)
+ add_test(regressiontest_executable
+ ${PYTHON_EXECUTABLE}
+ "${CMAKE_CURRENT_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec"
+ "${CMAKE_CURRENT_SOURCE_DIR}/regression.txt" "--program"
+ "${CMAKE_CURRENT_BINARY_DIR}/../src/cmark"
+ )
+
ELSE(PYTHONINTERP_FOUND)