summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2016-06-02 10:43:47 -0700
committerJohn MacFarlane <jgm@berkeley.edu>2016-06-02 10:45:19 -0700
commit8a53ee9b579fef9a75bd25f881827f28739a1f68 (patch)
treea921525ef8a37e0e147f2b203acc2f951de7b28d /test/CMakeLists.txt
parentf4a82cf6a5f553c2c886de02c23b41f06f8a19c6 (diff)
Added new roundtrip_tests.py.
This replaces the old use of simple shell scripts. It is much faster, and more flexible. (We will be able to do custom normalization and skip certain tests.)
Diffstat (limited to 'test/CMakeLists.txt')
-rwxr-xr-xtest/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 09af8a4..dd850b6 100755
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -48,9 +48,10 @@ IF (PYTHONINTERP_FOUND)
add_test(roundtriptest_executable
${PYTHON_EXECUTABLE}
- "${CMAKE_CURRENT_SOURCE_DIR}/spec_tests.py" "--no-normalize"
- "--spec" "${CMAKE_CURRENT_SOURCE_DIR}/spec.txt" "--program"
- "${ROUNDTRIP} ${CMAKE_CURRENT_BINARY_DIR}/../src/cmark"
+ "${CMAKE_CURRENT_SOURCE_DIR}/roundtrip_tests.py"
+ "--spec" "${CMAKE_CURRENT_SOURCE_DIR}/spec.txt"
+ "--no-normalize"
+ "--library-dir" "${CMAKE_CURRENT_BINARY_DIR}/../src"
)
add_test(regressiontest_executable