summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn MacFarlane <jgm@berkeley.edu>2014-11-29 11:00:48 -0800
committerJohn MacFarlane <jgm@berkeley.edu>2014-11-29 11:00:48 -0800
commitc301f6b6c6c3c870bc7a56334c3fd1d42356b736 (patch)
treef2a4919d4086ea504075595fb9427041ddbf4b5a /test/CMakeLists.txt
parent23cc43d2e77afd949a0951f97539fd63d50c3cee (diff)
Moved testing programs to test/.
Added test/CMakeLists.txt.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 0000000..6761317
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,24 @@
+# To get verbose output: cmake --build build --target "test" -- ARGS='-V'
+
+if (WIN32)
+ file(TO_NATIVE_PATH ${CMAKE_BINARY_DIR}/src WIN_DLL_DIR)
+ set_tests_properties(api_test PROPERTIES
+ ENVIRONMENT "PATH=${WIN_DLL_DIR};$ENV{PATH}"
+ )
+endif(WIN32)
+
+add_test(spectest_library
+ python "${CMAKE_CURRENT_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec"
+ "${CMAKE_SOURCE_DIR}/spec.txt" "--library-dir" "${CMAKE_BINARY_DIR}/src"
+)
+
+add_test(pathological_tests_library
+ python "${CMAKE_CURRENT_SOURCE_DIR}/pathological_tests.py"
+ "--library-dir" "${CMAKE_BINARY_DIR}/src"
+)
+
+add_test(NAME api_test COMMAND api_test)
+
+add_test(spectest_executable
+ python "${CMAKE_CURRENT_SOURCE_DIR}/spec_tests.py" "--no-normalize" "--spec" "${CMAKE_SOURCE_DIR}/spec.txt" "--program" "${CMAKE_BINARY_DIR}/src/cmark"
+) \ No newline at end of file