summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 80ecfc2..67d7b72 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -104,6 +104,9 @@ endif(MSVC)
set_property(TARGET ${LIBRARY}
APPEND PROPERTY MACOSX_RPATH true)
+# Avoid name clash between PROGRAM and LIBRARY pdb files.
+set_target_properties(${LIBRARY} PROPERTIES PDB_NAME cmark_dll)
+
generate_export_header(${LIBRARY}
BASE_NAME ${PROJECT_NAME})