summaryrefslogtreecommitdiff
path: root/src/components/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/Makefile.am')
-rw-r--r--src/components/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/components/Makefile.am b/src/components/Makefile.am
new file mode 100644
index 0000000..df629ab
--- /dev/null
+++ b/src/components/Makefile.am
@@ -0,0 +1,10 @@
+include ../common.mk
+bin_PROGRAMS = components largest_component strong_conn node_components
+components_SOURCES = components.c ../utils/utils.c ../include/utils.h
+components_LDADD = -lm
+largest_component_SOURCES = largest_component.c ../utils/utils.c ../include/utils.h
+largest_component_LDADD = -lm
+strong_conn_SOURCES = strong_conn.c ../utils/utils.c ../include/utils.h
+strong_conn_LDADD = -lm
+node_components_SOURCES = node_components.c ../utils/utils.c ../include/utils.h
+node_components_LDADD = -lm