summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Müller <jonathanmueller.dev@gmail.com>2016-06-27 20:36:00 +0200
committerJonathan Müller <jonathanmueller.dev@gmail.com>2016-06-27 20:36:00 +0200
commitcea0af4aad3208c190d006a7ba3497f4a3364b0a (patch)
tree90f1faa42240ce127828618e59ee633e6e2b87ac /CMakeLists.txt
parent9fe857d827b1fdb585e12d8387c3cb5fb5392c61 (diff)
Fix cmake warning about CMP0048
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52f8b4b..8a50f9e 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,13 @@
cmake_minimum_required(VERSION 2.8.9)
+
+# prevent ugly developer warnings because version is set directly, not through project()
+# it should be redone properly by using VERSION in project() if on CMake 3.x
+if(CMAKE_MAJOR_VERSION GREATER 2)
+ cmake_policy(SET CMP0048 OLD)
+endif()
+
project(cmark)
+
include("FindAsan.cmake")
if("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")