summaryrefslogtreecommitdiff
path: root/api_test/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2014-11-18 18:37:56 +0100
committerNick Wellnhofer <wellnhofer@aevum.de>2014-11-18 18:43:04 +0100
commit8dba3f7f3591f4271522835cb2057acf4ae56f53 (patch)
tree8bf044f7c0fa0e13925db0c64e8720a86c0b2336 /api_test/CMakeLists.txt
parent3f9fec6998fccabe5d61bfe84b9d2431f9d5ae53 (diff)
Start with tests for the C API
The C API tests can be run individually via build/api_test/api_test Or together with the spec tests via cmake --build build --target test
Diffstat (limited to 'api_test/CMakeLists.txt')
-rw-r--r--api_test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/api_test/CMakeLists.txt b/api_test/CMakeLists.txt
new file mode 100644
index 0000000..7b6c3d6
--- /dev/null
+++ b/api_test/CMakeLists.txt
@@ -0,0 +1,11 @@
+add_executable(api_test
+ harness.c
+ main.c
+)
+target_include_directories(api_test
+ PRIVATE
+ ${PROJECT_SOURCE_DIR}/src
+ ${PROJECT_BINARY_DIR}/src
+)
+target_link_libraries(api_test libcmark)
+