summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Wellnhofer <wellnhofer@aevum.de>2015-04-26 21:51:10 +0200
committerNick Wellnhofer <wellnhofer@aevum.de>2015-04-26 21:51:10 +0200
commit040470aaced3f7f82de713193e48cc1acaab381d (patch)
treeb001fc0899393afa980cc69f56d50483c74be40a /src/CMakeLists.txt
parent141fb056c7a95ce12ed845a24bdf3f9af66afdfb (diff)
Suppress warnings about Windows runtime library files
Visual Studio Express editions do not include the redistributable files. Set CMAKE_INSTALL_SYSTEM_RUNTIME_LIBS_NO_WARNINGS to suppress warnings.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 894b2c1..ba3e18e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -111,6 +111,7 @@ if (MSVC)
APPEND PROPERTY LINK_FLAGS /INCREMENTAL:NO)
endif(MSVC)
+set(CMAKE_INSTALL_SYSTEM_RUNTIME_LIBS_NO_WARNINGS ON)
include (InstallRequiredSystemLibraries)
install(TARGETS ${PROGRAM} ${LIBRARY}
RUNTIME DESTINATION bin